Dashboard may be slow and show dated information

Incident Report for Inky

Resolved

The backlog seems to have caught up, and Dashboard operations are back to normal.
Posted Oct 21, 2025 - 14:57 UTC

Identified

Due to the AWS outage yesterday, users may experience the INKY Dashboards running a bit slower and showing some dated information on the Summary page. AWS is working through the backlog of data and as that is completed, the Dashboard speed and accuracy should return.
Posted Oct 21, 2025 - 13:36 UTC
This incident affected: Dashboard Services (Dashboard Services US, Dashboard Services EU).